通达信芙蓉出水公式

软件控 2022-03-16 324

通达信芙蓉出水公式

源码

AAAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAAA+7*REF(AAAA,1)+6*REF(AAAA,2)+5*REF(AAAA,3)+4*REF(AAAA,4)+3*REF(AAAA,5)+2*REF(AAAA,6)+REF(AAAA,8))/36;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
DRAWBAND(VAR1,RGB(155,50,50),VAR6,RGB(250,250,0));
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
短线:VAR1,COLORWHITE;
中线:VAR6,COLORYELLOW;
下跌:IF(VAR1=VAR6,VAR6,DRAWNULL),COLORGREEN;
N1:=5;N2:=7;N3:=11;
EM1:=EMA(C,N1),COLORWHITE;
EM2:=EMA(C,N2),COLORRED;
EM3:=EMA(C,N3),COLORGREEN;
TJ:=BETWEEN(EM2,EM1,EM3);MA20:MA(C,20)LINETHICK3;
IF(MA20>REF(MA20,1),MA20,DRAWNULL)COLORRED,LINETHICK3;
立桩量:=FILTER(TJ=0,5);{芙蓉出水}
MA200:=EMA(CLOSE,20);
MA400:=EMA(CLOSE,40);
MA600:=EMA(C,60);
AA:=BARSLAST(MA400>MA600 AND (MA200=MA400 OR MA200>MA400));
BB:=REF(COUNT(C
MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;
芙蓉出水:=BB AND CC;
STICKLINE(芙蓉出水,C,O,2,0),COLORYELLOW;
DRAWTEXT(芙蓉出水,L-L*0.0005,'芙蓉出水'),COLORYELLOW;
最新回复 (0)
返回
发新帖