点石成金 指标

软件控 2022-03-08 505

{公式名称: 点石成金
公式描述: 
无参数
公式类型: 技术指标公式-其他类型
画线方法: 副图
公式版本: 0
显示小数: 缺省位数
坐标线位置: 自动
额外Y轴分界: 无

参数精灵:无
用法注释:无
公式源码:}
XA_1:=100-3*SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1);
XA_2:=100-3*SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1);
XA_3:=XA_1<REF(XA_2,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(XA_3 AND COUNT(XA_3,30)=1,15,1),COLORMAGENTA;
XA_4:=WINNER(CLOSE+CLOSE*15/100)*100;
XA_5:=WINNER(CLOSE+CLOSE*0/100)*100;
XA_6:=XA_4-XA_5;
XA_7:=(WINNER(CLOSE-CLOSE*0.1/100)-WINNER(CLOSE-CLOSE*15/100))*100;
XA_8:=XA_6<3 AND XA_7<0.5 AND OPEN!=LOW;
XA_9:=DYNAINFO(6);
XA_10:=IF(LOW>XA_9,0,IF(HIGH<XA_9,1,(XA_9-LOW+0.01)/(HIGH-LOW+0.01)));
XA_11:=VOL/WINNER(LOW);
XA_12:=REF(HHV(CLOSE,120),1);
XA_13:=REF(LLV(CLOSE,120),1);
XA_14:=100*(CLOSE-XA_13)/(XA_12-XA_13);
XA_15:=XA_10>0 OR XA_10=1;
XA_16:=XA_15 AND XA_11/REF(XA_11,3)>=3 AND XA_14<80;
XA_17:=REF(XA_16,1) OR REF(XA_16,2) OR REF(XA_16,3) OR REF(XA_16,4);
XA_18:=XA_16 AND XA_17;
XA_19:=IF(FILTER(XA_16,3),5,0);
XA_20:=IF(FILTER(XA_18,3) OR XA_8,10,0);
资金进场日:IF(XA_19>0,8,DRAWNULL),STICK,COLORYELLOW,LINETHICK3;
资金加仓日:IF(XA_20>0,15,DRAWNULL),STICK,COLORMAGENTA,LINETHICK4;
DRAWTEXT(XA_19,8,2);
DRAWTEXT(XA_20,17,3);
XA_21:=(CLOSE*2+HIGH+LOW)/4*10;
XA_22:=EMA(XA_21,13)-EMA(XA_21,34);
XA_23:=EMA(XA_22,5);
XA_24:=2*(XA_22-XA_23)*5.5;
主力:XA_24,COLORRED,LINETHICK2;
XA_25:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
XA_26:=EMA(3*XA_25-2*SMA(XA_25,18,1),5);
XA_27:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;
XA_28:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
XA_29:=(HIGH+LOW+CLOSE)/3;
XA_30:=(XA_29-MA(XA_29,14))/(0.015*AVEDEV(XA_29,14));
XA_31:=(XA_29-MA(XA_29,70))/(0.015*AVEDEV(XA_29,70));
XA_32:=IF(XA_30>=150 AND XA_30<200 AND XA_31>=150 AND XA_31<200,10,0);
XA_33:=IF(XA_30<=(-150) AND XA_30>(-200) AND XA_31<=(-150) AND XA_31>(-200),(-10),XA_32);
XA_34:=(CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*100;
XA_35:=100-ABS(XA_34);
XA_36:=IF(XA_35<90,XA_35,100);
XA_37:=IF(XA_28>0,XA_28,0);
XA_38:=IF(XA_31>=200 AND XA_30>=150,15,IF(XA_31<=(-200) AND XA_30<=(-150),(-15),XA_33))+60;
XA_39:=XA_37>48 AND XA_38>60 AND XA_36<100;
DRAWTEXT(XA_39 AND COUNT(XA_39,30)=1,15,4),COLORFFCC66;
T1:(XA_3 AND COUNT(XA_3,30)=1)*28,COLORWHITE;
T:(COUNT(XA_16,30)>=3 AND COUNT(XA_18,30)>=3)*38,COLORWHITE;
DRAWICON(CROSS(主力,T),主力+0,1);
DRAWICON(CROSS(T,主力),T+0,2);


最新回复 (0)
返回
发新帖